sábado, 17 de abril de 2010

/opt/local/lib/ruby/vendor_ruby/1.8/rubygems/spec_fetcher.rb:232: warning: getc is obsolete; use STDIN.getc instead

Apos instalar o ruby 1.8.7 via MacPorts ao instalar novas GEMS pode gerar esse erro
"/opt/local/lib/ruby/vendor_ruby/1.8/rubygems/spec_fetcher.rb:232: warning: getc is obsolete; use STDIN.getc instead"

para arrumar 'e simples: basta setar a variavel de ambiente GEM_HOME
atraves do comando: export GEM_HOME=/opt/local/lib/ruby/gems/1.8

Nenhum comentário:

Postar um comentário